It is currently Wed Nov 20, 2019 4:50 pm


All times are UTC




Post new topic Reply to topic  [ 13 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Cubiquity and Ambient Occlusion problem
PostPosted: Sun Oct 09, 2016 4:34 pm 
User avatar

Joined: Tue Feb 05, 2013 5:44 pm
Posts: 33
The bad thing about this fix is that in nearly triples the amount of vertex data sent to the graphics card along with all the normal data. On my machine this absolutely kills the FPS. I will probably end up hacking in the Minecraft smooth lighting algorithm into Cubiquity (it looks better than the SSAO shaders anyway).


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Cubiquity and Ambient Occlusion problem
PostPosted: Sun Oct 09, 2016 10:33 pm 
User avatar

Joined: Tue Feb 05, 2013 5:44 pm
Posts: 33
SSAO seems to work with deferred rendering. Also I couldn't get shadows working with forward rendering so I had to switch to deferred... strangely, the shadows look fine in the editor even in forward mode. I'm not sure what the problem is, but none of the obvious solutions worked.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Cubiquity and Ambient Occlusion problem
PostPosted: Mon Oct 10, 2016 5:39 pm 
Developer
User avatar

Joined: Sun May 04, 2008 6:35 pm
Posts: 1827
Dynasty wrote:
The bad thing about this fix is that in nearly triples the amount of vertex data sent to the graphics card along with all the normal data.

Ah, so that answers my previous question about why the flat shading still works. Apparently Unity automatically handles duplicating the vertices which will indeed increase the size of the meshes significantly.
Dynasty wrote:
SSAO seems to work with deferred rendering. Also I couldn't get shadows working with forward rendering so I had to switch to deferred... strangely, the shadows look fine in the editor even in forward mode. I'm not sure what the problem is, but none of the obvious solutions worked.

I don't recall seeing any problems here, and I have never tested with Unity's deferred shading pipeline. I must admit that I am quite far behind the latest version of Unity though (the highest I tested on was maybe ver 5.1?) so I wonder if it is a recent (or platform-specific?) problem?


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net