It is currently Wed Nov 20, 2019 4:01 am


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: [Resolved] Failing voxel traits test
PostPosted: Tue Feb 07, 2012 5:29 pm 
Developer
User avatar

Joined: Sun May 11, 2008 4:29 pm
Posts: 198
Location: UK
With the recent changes voxel type traits, one of the tests seems to be failing. The output is:
Code:
********* Start testing of TestVoxels *********
Config: Using QTest library 4.4.3, Qt 4.4.3
PASS   : TestVoxels::initTestCase()
FAIL!  : TestVoxels::testVoxelTypeLimits() Compared floats are not the same (fuzzy compare)
   Actual (VoxelTypeTraits<DensityFloat>::minDensity()): -3.40282e+38
   Expected (FLT_MIN): 1.17549e-38
   Loc: [/home/milliams/polyvox/tests/TestVoxels.cpp(59)]
PASS   : TestVoxels::cleanupTestCase()
Totals: 2 passed, 1 failed, 0 skipped
********* Finished testing of TestVoxels *********
I can confirm the failing test on two other Linux boxes too. Basically, the difference is that the DensityFloat type's min value is being defined as -std::numeric_limits<DensityFloat::DensityType>::max() (the most negative number possible) but the test is checking for it being the smallest (closest to zero) positive number possible. I'd fix it myself but I'm not sure which way you intended it to work.

_________________
Matt Williams
Linux/CMake guy


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Failing voxel traits test
PostPosted: Wed Feb 08, 2012 9:47 am 
Developer
User avatar

Joined: Sun May 04, 2008 6:35 pm
Posts: 1827
Thanks, it should be the most negative (-FLT_MAX) rather than the smallest positive (FLT_MIN), so I've fixed the test.

I didn't get an email from CDash to say it was failing though... did you get one or you just happened to notice? Perhaps it only sends one when a test breaks, and it had never passed in the first place?


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Failing voxel traits test
PostPosted: Wed Feb 08, 2012 9:59 am 
Developer
User avatar

Joined: Sun May 11, 2008 4:29 pm
Posts: 198
Location: UK
No, I didn't get an email. I noticed when I ran the tests locally. The test did fail overnight though but you must be right that it only sends an email when a test which was previously working fails.

The test is working fine now locally.

_________________
Matt Williams
Linux/CMake guy


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net