It is currently Mon Aug 03, 2020 9:10 am


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Windows - problem building polyvox.
PostPosted: Mon Mar 04, 2013 2:49 am 

Joined: Sun Mar 03, 2013 11:23 am
Posts: 4
I have:
Windows 7 pro
Qt 5.0.1
Qt 4.8.4
Cmake 2.8.10.2
Code::blocks 10.5
And minGW 4.4.1

And I'm trying to build polyvox 0.2.1

So I follow what's written here: http://www.volumesoffun.com/polyvox/doc ... stall.html
For the record, I'm total noob with Cmake, never used it.
Since Cmake doesn't seem to automatically detect everything, I must point most of the paths manually, and after pointing to my polyvox dir and the build subdir, I don't seem to find the "project file" that I'm supposed to open with my IDE.

Here's the list of what's in my polyvox build subdir:

cmake_install.cmake
cmakecache.txt
cpackconfig.cmake
cpacksourceconfig.cmake
ctesttestfile.cmake
dartconfiguration.tcl
makefile
placeholder.txt (not relevant)

Of course, I suppose I did something wrong, but since I don't know how.

Here's the log of Cmake with debug infos:

Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
Looking for Q_WS_X11
Looking for Q_WS_X11 - not found
Looking for Q_WS_WIN
Looking for Q_WS_WIN - found
Looking for Q_WS_QWS
Looking for Q_WS_QWS - not found
Looking for Q_WS_MAC
Looking for Q_WS_MAC - not found
Found Qt4: D:/Qt/4.8.4/bin/qmake.exe (found version "4.8.4")
Could NOT find SWIG (missing: SWIG_EXECUTABLE SWIG_DIR)
Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS)
Found OpenGL: opengl32
`sphinx-build` was not found. Try setting SPHINXBUILD_EXECUTABLE to its location.

-- The following features have been enabled:

* Examples , Examples of PolyVox usage
* Tests , Unit tests

-- The following RECOMMENDED packages have been found:

* Qt4 , C++ framework , <http://qt-project.org>
Building the examples
Building the tests

-- The following REQUIRED packages have been found:

* OpenGL

-- The following features have been disabled:

* Bindings , SWIG bindings
* API docs , HTML documentation of the API
* Qt Help , API docs in Qt Help format
* Manual , HTML user's manual

-- The following OPTIONAL packages have not been found:

* Doxygen , API documentation generator , <http://www.doxygen.org>
Building the API documentation
* SWIG , Bindings generator , <http://www.swig.org>
* PythonLibs , Programming language , <http://www.python.org>


Summary
-------
Library type: STATIC
Build examples: ON
Build tests: ON
Build bindings: OFF
API Docs available: NO
- Qt Help bundling: OFF
Build manual: OFF

Configuring done
Generating done


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Windows - problem building polyvox.
PostPosted: Mon Mar 04, 2013 9:11 am 
Developer
User avatar

Joined: Sun May 04, 2008 6:35 pm
Posts: 1827
It looks like CMake has created a makefile rather than a Code::Blocks project file. On Windows I only use Visual Studio so I don't have much experience of other systems, but I came across this:

http://www.cmake.org/Wiki/CMake_Generat ... _Generator

It seems that creating makefiles is the usual process when using CMake with Code::Blocks, but that there is some support for generating real Code::Blocks project files in recent versions.

Are you running CMake from the command line or through the GUI? If you use the GUI you should get a dialog where you can choose the desired output type, so maybe you see a good option here? I just tried it and the best I saw was 'CodeBlocks - MinGW Makefiles' and I guess this is the option you tried already?

Does the makefile you have actually work (i.e. did you try running make)? It seems that Code::Blocks also has the option to use an existing Makefile, and this may be what CMake is expecting you to do with its output. See here:

http://forums.codeblocks.org/index.php?topic=199.0

If you can't get any of this to work, then a fall back option is to skip the PolyVox build process and instead just add all the headers and source files directly into your own project. You might have to fiddle around to get the paths right though - I should add something about this to the instructions.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Windows - problem building polyvox.
PostPosted: Mon Mar 04, 2013 2:31 pm 

Joined: Sun Mar 03, 2013 11:23 am
Posts: 4
Yep, I'm using the GUI and you can hit configure once in the beginning and choose what compiler you want, did this, then if you hit "configure" again, it just reloads vars from the array, so you can't choose anymore (except by wiping the cache).

The codeblocks forum info is outdated, from my search what you have to do with latest versions is create an empty project, rightclick on the project, go to properties and check "This is a custom Makefile"
But since I never worked with makefiles, I don't know where to go from there, after linking the path of the makefile.
I've also read that c::b fails to go to the makefile subpath so you have to go to "Project build options" then modify the "Make commands" tab.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Windows - problem building polyvox.
PostPosted: Mon Mar 04, 2013 3:40 pm 
Developer
User avatar

Joined: Sun May 04, 2008 6:35 pm
Posts: 1827
I'm afraid I can't really help with that, as I've never used Code::Blocks myself. Maybe you can ask on the Code::Blocks forum? Perhaps there are other people there who use it with CMake and can give a better answer.


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net